Powerboat Forums at SpeedWake banner
1 - 5 of 5 Posts

·
Registered
Joined
·
666 Posts
Discussion Starter · #1 ·
I have an Alpha1. I and trying to get the right lower water pump hsg. I order a sierra (sie-3420) it look like mine but the bottom side where is mount to the lower unit is different. Mine does not have a groove for an o-ring. The one I received has a groove for an o-ring making it about 1/4 longer not letting the base go all the way down. The lower unit was changed out and I have no information.I can’t read the serial # and I don’t know what year it is. The dive shaft is not spring loaded and it has the two bolts above the prop on the bottom. My understanding making it an Alpha 1.
 

·
Registered
Joined
·
3,516 Posts
Maybe you didn't get the whole base assembly out of the drive yet...
Can you take a close-up picture of your drive where the pump base goes. and a pic of the new base you received..

PS, This should be in the Tech section..
 

·
Registered
Joined
·
666 Posts
Discussion Starter · #3 ·
Fyhr Factor said:
Maybe you didn't get the whole base assembly out of the drive yet...
Can you take a close-up picture of your drive where the pump base goes. and a pic of the new base you received..

PS, This should be in the Tech section..
Ill ck it out and see it was getting dark when was atemping to do this. Thanks
 

·
Registered
Joined
·
666 Posts
Discussion Starter · #4 ·
Fyhr Factor said:
Maybe you didn't get the whole base assembly out of the drive yet...
Can you take a close-up picture of your drive where the pump base goes. and a pic of the new base you received..

PS, This should be in the Tech section..
I finished up my water pump job. You were right there was a piece of the pump still in it. The reason I didn’t notice…the lower part that stayed in it was blue in color like a seal. The new lower pump hsg fit just fine now. Thanks for your time.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top