Powerboat Forums at SpeedWake banner
1 - 5 of 5 Posts

·
Registered
Joined
·
4,109 Posts
Discussion Starter · #1 ·
how do I trouble shoot a bad fuel pump? 2000 502mpi, boat was running fine on the way home, running about 4000 rpm and it felt as if somebody just shut the motor off. tried restarting, it would rune for a second or two then die, after a couple more tries it just wouldnt start up at all.

Unfortunately I was about 18 miles across the bay in about 5' swells, BIG THANKS TO BAJA WILL from OSO, Will towed me a couple miles until Se Tow came and got me, 3 hr trip home. :(

All the bad press on oso about, Seas Tow, I have nothing but great experiences with our local guys. Tow would have been $600 if I wasnt a member.
 

·
Registered
Joined
·
1,802 Posts
I would guess water in the fuel. Dump out your fuel/water seperator and it may be all water. Been there. If the vent on the fuel tank is not plumbed properly and you get into big water, you can injest water into the tank through the vent.

BT :cool:
 

·
Registered
Joined
·
19 Posts
there is a fuse on the back of the motor for the fuel
pump too make sure you check that....but there is
a problem with alot of water in the fuel around us...
and your fuel pump has been changed before ..

good luck
 

·
Registered
Joined
·
4,109 Posts
Discussion Starter · #5 ·
I'll give you a call Stan if I cant figure it out, havent looked at it yet. Where is the fuel pressure fuse?

OP gauge was still reading fine, are you talking about the sensor on the back of the block?
 
1 - 5 of 5 Posts
Top