Powerboat Forums at SpeedWake banner

1 - 9 of 9 Posts

·
Registered
Joined
·
257 Posts
Discussion Starter · #1 ·
I'm hearing a small whistle coming from the engine compartment when at idle. I believe it's coming from the Corsa exhaust, everything is running fine. Anyone else having this problem. I think it's from the internal flapper/bypass.
 

·
Registered
Joined
·
1,342 Posts
i get it too, just at idle dunno if its from the flappers inside or what I have lightnings on mine with qwik n quiet and the valve removed inside, so theres just a rod going thru which may be my whistle.
 

·
Registered
Joined
·
550 Posts
I get it too, mine goes away when you increase RPM's.
I think it's belts or power steering pump ?
 

·
Registered
Joined
·
261 Posts
I seem to get a whisle from the FI I believe it is fron the idle air control thingy. But who knows

mm
 

·
Registered
Joined
·
5,548 Posts
The 496 engines whistle just off idle....1500-1800 maybe more? Usually under heavy load, like coming out of the hole. I was told it was the spark arrestor....
 

·
Registered
Joined
·
406 Posts
I got the same thing with my 7.4MPI. Whistles just above idle and around 2500RPM. Was told an IAC muffler would fix it. Mercury sells it for like $3.
 

·
Registered
Joined
·
50 Posts
Splitdecision271 said:
It doesn't really bother me, I just wanted to know if others were experiencing the same problems with their switchable exhaust.
I don't have switchable exhaust, just the Quik&Quite Y-pipe. Never hear any whistle out of my 6.2's at idle or any other time.
 
1 - 9 of 9 Posts
Top