Powerboat Forums at SpeedWake banner

1 - 4 of 4 Posts

·
Registered
Joined
·
70,399 Posts
Discussion Starter #1
I need some help on troubleshooting my K plane problems. Only the starboard side, it goes up, but not down at all. The trailer toggle will not bring either of them up or down. I checked for a blown fuse on the trim motor and found no loose or leaking hoses. Any other idea why one would work and not the other. 29 Baja Outlaw. At least I had them both stuck fully up all weekend or I would of been really P.O.'d:mad:
 

·
Super Goon At Large
Joined
·
6,103 Posts
Well Allan I would say check the soleniod at the pump, They tend to go bad rather quickly or at least mine have anyway. This would make it run one way and not the other. As for why the Trailer switch will not cause them to run, Mine has a trailer switch but it only runs the drives up not the K-planes. I have two switches for the K-planes and two for the drives and then the Tailer switch for the drives. I hope this help a little. If ya get into it and need some help call me and maybe I can swing by and we can check it out...... Later..
 

·
Registered
Joined
·
70,399 Posts
Discussion Starter #3
Thanks Tim, Carina called a place (no names) today about it, all they can say is about 400-800 to fix (yeah right). Any way a fat chick got on my boat at lake travis and stepped in the passanger bolster seat and bent it, so I am going to see if Baja will help any with that. I dont think a 170 lbs. chick should bend a seat. I will give you a call if I feel like getting back in that little space to check anything out.
 

·
Super Goon At Large
Joined
·
6,103 Posts
Yea 170 lbs should not bend it....... now 370 migth but not 170...... Yea I know it is a bad place to get too.... I will be working on mine if and when I get home... Later...
 
1 - 4 of 4 Posts
Top