Powerboat Forums at SpeedWake banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4,109 Posts
Discussion Starter · #1 ·
Do I need any sealant when I am reinstalling my OD or are the (2) o rings for the oil and water passage enough?

Also, do you need to align the motor every time you reinstall? My motor was out last summer (15-20 hrs ago) and everything was aligned properly then.
 

·
Registered
Joined
·
525 Posts
Bravo 1 drive?

There is a kit you buy from mercruiser that has o rings that go on the shaft (3), oring for the water (1), oring for the oil from the reservoir (1).

I think that's it for O rings.

Grease the U joints with some good waterproof grease, lots of grease on the splines and the shaft and slide it in.

Rule of thumb IMO is if the drive slides on and off the boat easily the motor is aligned.
 

·
Registered
Joined
·
4,109 Posts
Discussion Starter · #3 ·
Thanks, that's what I did, my rule of thumb is if I didnt force it in it must be OK.

just got the drive back, new XR uppers and the lower got new bearings. Should be all set for the summer!
 

·
Registered
Joined
·
3,516 Posts
Not Right said:
Thanks, that's what I did, my rule of thumb is if I didnt force it in it must be OK.

just got the drive back, new XR uppers and the lower got new bearings. Should be all set for the summer!
That's right, NR, just what he said.. And I hope your done with the problems for awhile. Good luck.. :)
 

·
Registered
Joined
·
1,005 Posts
There is a tool for checking engine alignment. But seeing as how we passed you yesterday, I guess you got her back together successfully. ;)
 

·
Registered
Joined
·
4,109 Posts
Discussion Starter · #6 ·
Yeah, ran great all weekend, we should have skipped Harborfest and ran to the Tiki Bar or something.
 
1 - 6 of 6 Posts
Top