Powerboat Forums at SpeedWake banner
1 - 8 of 8 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter · #1 ·
I have a 88 Power Play/ Powerquest Conquest about 4000 lbs. I popped the 454 and dropped in a 502 502hp/567ft. With the 454 trimed out I would hit 58 on GPS at 4800 with a 23p 3 blade prop, Now with the same prop 4500rpm's 53mph at 4500. Any thoughts on a new prop? Thanks in advance
 

·
Registered
Joined
·
6,711 Posts
blown96w said:
The 454 was a 1988 365 mag built to the to the 420hp motor specs The 502 is a GM performance crate engine with CMI Etop headers
I swapped out a 7.4/330 for the ZZ502/502. Ran it for 4 seasons in my Wellcraft 23 Nova. Great engine, never missed a beat.

With my 7.4/330 I ran a Mirage 23 (old style, not a Mirage Plus). With ethe ZZ502 I ended up with a 25 Mirage Plus, labbed by Throttle Up. RPM's with the labbed 25 were around 5300, depending on weather and chop.

Side note... if you haven't done so already, suggest you add an oil temp sender to be sure oil temps are in the proper range. You may need a bigger oil cooler than the 454/385 type.

Have fun with the new power :)
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #6 ·
Side note... if you haven't done so already, suggest you add an oil temp sender to be sure oil temps are in the proper range. You may need a bigger oil cooler than the 454/385 type.


What temp range should I be in?
 

·
Registered
Joined
·
3,516 Posts
From what you describe, it sounds more like a engine tuning/spark/carburetor or fuel delivery problem, not the prop, that will come Later, but after you get your engine running as it should 1st

On my SB, the oil temps run in the 180-190 range at cruise..and will climb to the 210-220 range at wot with no cooler..
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top