Powerboat Forums at SpeedWake banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I would like to install the Eddie Marine SS water pump bypass kit which includes a SS thermostat housing. The SS thermostat housing does not have accomodations for the engine water temp sender unit or the water temp alarm sender unit.

The engines are 1995 Mercruiser 502 Mag MPI.

Any good suggestions on where to relocate these sending units.

I was considering fabbing an in line 1 inch Tee in the water discharge hoses to the manifolds -close to the thermostat housing on each side.

I know this forum has lot of experience, and was hoping that someone has already done this installation and may have a better suggestion.
 

·
Premium Member
Joined
·
8,666 Posts
If they are stock 502 MPI's,,,,,, dont do it !!!!!
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Thanks for the reply.

Being new to the MPI what are the dangers with doing the SS water bypass and thermostat housing install?

I have a set of Mercruiser Gill headers that i will also be installing.
 

·
Registered
Joined
·
793 Posts
BB Thunder said:
Thanks for the reply.

Being new to the MPI what are the dangers with doing the SS water bypass and thermostat housing install?

I have a set of Mercruiser Gill headers that i will also be installing.
As obnoxus said, leave it stock. You are going to gain nothing but headache's from messing with what Merc has done. Crossovers look nice, but they can cause issues with water temp and water pressure. If they lower the water temp they will mess up the computer as it needs to read a certain temp.

Switching the exhaust is fine.
 

·
Registered
Joined
·
1,771 Posts
BB Thunder said:
The engines are 1995 Mercruiser 502 Mag MPI.


I was considering fabbing an in line 1 inch Tee in the water discharge hoses to the manifolds -close to the thermostat housing on each side.

I
That hose can have a combination of heated and any excess water not going thru the motor, which would be cold lake temp water. Can give the ECM a false temp reading, and as previoulsy mentioned, EFI's need the correct temp reading for fuel mixture.
 

·
Rock Steady
Joined
·
13,139 Posts
Agree, I had those same motors in my last Scarab. Keep the circulation pump, don't bypass. Use that money to dress up other things and get some more speed!!!
 
1 - 7 of 7 Posts
Top