Powerboat Forums at SpeedWake banner

1 - 7 of 7 Posts

·
Registered
Joined
·
12,354 Posts
Discussion Starter #1
I have a 242 Formula with twin 350's and alpha drived. I found out last week the hard way that it has seawater pumps on it. I hooked it up in the driveway and fired up the engines one at a time on the muffs. Ran great until I got to the launch and found one engine would barely turn over and then it made a hellacious squealing noise. On further inspection, I saw which pulley wasn't turning, the deduced it was a seawater pump. Yep, burned up the impeller.

What I need to know, is can I run it on the seawater pumps only. There is a hose attachment for running them on. (found it after seeing the lines running from the pumps) In other words, are there impellers in the drive also? And will I burn them up by running on the hose connection. I can't see having to have three hoses hooked to the boat at once to run the engines. (two muffs and the hose connection)
 

·
Registered
Joined
·
70,399 Posts
cuda,Yes there are impellers in the drive.,but I would not run it without the sea pump.....

I think the hook up;s you are reffering to are for flush kits,you do not need 3 hoses
 

·
Registered
Joined
·
12,354 Posts
Discussion Starter #3
I can't see them engineering a boat that you need three hoses to run it. I know last year I bought a used alpha for my other Formula, and when I had it installed, my mechanic was checking it out and it did not have an impeller in the outdrive. He said then that the boat it came from must have had raw water pumps.
 

·
Registered
Joined
·
70,399 Posts
cuda,I might be wrong,but I believe that mechanic's not correct. I will try to look up yhe info,unless another member come's up with it 1st
 

·
Registered
Joined
·
1,637 Posts
I was told that even if you run engine mounted pumps you still need to have the one in the drive because it cools the drive oil too and the drive may overheat without it.
I was planning to switch to an external pickup and a Bravo type raw water pump, mechanic said to use the drive pump to supply water to a drive shower.

Don't try to run both engines on one hose, not enough water supply.
Only run one engine at a time.
 

·
Registered
Joined
·
12,354 Posts
Discussion Starter #6
I have FWC on my other Formula too, but it is fed through the drive like all raw water alphas. I have been told I may have to put a seawater pump on it when the water gets real warm here. So far so good with it. Runs 160 all the time.
 
1 - 7 of 7 Posts
Top