Powerboat Forums at SpeedWake banner
1 - 20 of 30 Posts

·
Registered
Joined
·
3,003 Posts
Discussion Starter · #1 ·
today I was out on the boat by myself and wanted to do some testing with the k&n filter I just put on yesterday, the boat seemed to run fine hit the throttle a few times and it felt fine yesterday I pulled a skier with no problems but when I got to some open water I went WOT it bogged I backed off it seemed fine gave it throttle it bogged again then it got worse I couldnt get the motor over 2900 rpms(put on the stock arrestor no change) went back to the dock (20 mins idleing up the river) checked a few things oil good, wires seem fine (it didnt sound like it was missing) checked one plug white no sign of anything strange it may be a hair lean, prop seemed fine I couldnt feel and damge to it. this may or may not have anything to do with it but since I had the boat once in awhile it would come off plane by itself and I would have to give it full throttle to get it back up to speed but in never bogged before, any ideas I think I have a good guess but Ill wait to hear from you guys
 

·
Registered
Joined
·
3,003 Posts
Discussion Starter · #6 ·
it should be still under warrenty, if its not Ill check fuel presure first I belive it should be 40 lbs, could any thing else do it?
 

·
Registered
Joined
·
3,003 Posts
Discussion Starter · #8 ·
if I rember correctly its dosent have a mass air flow it has a sensor monitoring manifold pressure
 

·
Registered
Joined
·
250 Posts
A lot of engines that have airflow meters have problems with K&N filters due to the oil. The oil seems to coat the sensor and inhibits it's operation. Sometimes this can happen after a while and many techs are not aware of the problem-so a lot of air flow meters are getting replaced for no good reason.:(
 

·
Registered
Joined
·
259 Posts
CRMAx, I am not a mechanic or anything but after reading above I would go back and try the old Flame arrestor. You and I have the same basic setup. The only diff. is you trimmed your gasket inside the air intake and I did not. You maybee getting to much air and not enough fuel now.
 

·
Registered
Joined
·
3,003 Posts
Discussion Starter · #12 ·
thats the first thing I thought so when it happen I put the old flame arrestor back on and it made no differance, I have I have about 6 days at 2-3 hours of running time on it since trimming the gasket so I dont think thats it. now it could have made a low fuel presure problem alot worse by leaning it out to much. I know there are 2 ways to change the fuel mixture reprogram or change the regulator. do you have any idea what fuel presure your running as far as I know you have the fastest stock 7.4 Ive heard of except for a cat
 

·
Registered
Joined
·
259 Posts
One other thing to think about. They say when "looking for ants you usaully get run over by elephants". Could you have some bad Fuel. I allways put PRI-G in my tank before running and after re-fueling. It will get rid of any contaminants in there.
 

·
Registered
Joined
·
250 Posts
Some can be cleaned and will work properly again, others will not clean up and need to be replaced. Usually the longer the filter is used before the failure the more damage is done. I am not familiar enough with your engine to tell whether this would even apply.

The white plug kind of bothers me- If the new filter made it too lean under load and the old filter did not change anything, you may have done some significant damage. A compression test might be in order. And if you are still under warranty I would not mention the K&N installation.
 

·
Registered
Joined
·
259 Posts
As far as speed goes, that may be driver related. The best yet is 76 on my speedo and 67.4 on GPS(, Yep I went both up and down the lake only .3 in difference), (1/4 tank fuel and my bro and I) about 420 lbs in riders. If I have him up front with me I run better because the boat has alot of bow rise and I think it balances it out.
 

·
Registered
Joined
·
3,003 Posts
Discussion Starter · #16 ·
I put the filter in the trunk of my car the same day, the marina is surpose to look at it this week
 

·
Registered
Joined
·
259 Posts
CR, any resolution on what may have caused the problem yet? I hope things work out for you. It sucks when your machine isn't running at top conditon. Boats are like older muscle cars, have to tighten this and check that.
 
1 - 20 of 30 Posts
Top